
On 28-3-2013 16:59, Markus Engel wrote:
Okay, so here's my branch: https://code.launchpad.net/~engelmarkus/inkscape/cppify
So great to see someone work on this!!! I'm excited about finally getting rid of the overly verbose and bugprone inheritance code.
I have an important comment about function naming. "sp_feTile_write" is changed to "::onWrite", which is not actually what the function does. It's more like a "::doWrite". For me this kind of naming is very confusing, so I'd rather have it changed simply to "::write". Maybe for some functions it makes sense ("sp_flowtext_child_added" -> "::onChildAdded"), but for most it is not an improvement to change the name of the function ("sp_flowtext_set" -> "::onSet" is particularly bad).
I hope you've automated a lot of those changes... So, at least for a first pass, please don't change the function names. Just remove the "sp_classname_" part, but keep the rest untouched.
Thanks! Johan