On Jan 10, 2010, at 12:00 AM, Diederik van Lierop wrote:
I've just made some changes to the snapping API today, as Joshua already noted. Shouldn't take you more than a few minutes extra though :-)
Can you take a quick peek? It looks like snap-candidate.h has an error in the initializer in line 116.
SnapCandidateItem(SPItem* item, bool clip_or_mask, Geom::Matrix _additional_affine) : item(item), clip_or_mask(clip_or_mask), additional_affine(additional_affine) {}
I think the parameter needs to get rid of that extra underscore.
Also.. for the initialization, consider keeping that on separate lines. Makes it a little more readable, and also makes diff's easier to view over time. It also makes things easier to breakpoint and walk in the debugger:
SnapCandidateItem(SPItem* item, bool clip_or_mask, Geom::Matrix _additional_affine) : item(item), clip_or_mask(clip_or_mask), additional_affine(additional_affine) {}
Thanks.