
Hello all,
In spirit of codebase cleanup, I'd like to propose a simple renaming idea, to make things more clear to the developer (to me, at least :) I think, apart from C++-ifying, it would be a lot clearer when the SPObjects are renamed to either "SPObject" (the same :P) or "SVGObject". An example:
SPPath represents svg:path in the SVG. When svg:path is added to SVG, Inkscape immediately generates an SPPath for it. I therefore propose to rename it to something that reflects this aspect of SPPath: that it is directly linked to something in SVG. SPDesktop for example is *not*. SPDesktop => SPDesktop, stays the same SPPath => SVGPath, meaning it represents some element in the SVG. SPShape => SVGShape (since all its derivates are SVG elements) SP_IS_PATH => IS_SVG_PATH (I never understood why it isn't named IS_SP_PATH)
SPNamedview => SVGNamedview ? Now this one is a troublemaker. Because it is linked to sodipodi:namedview in the XML. I still think we should rename it with SVG up front, because it is linked to something in the SVG, does not matter what its name in XML is.
Please, if this above all is non-sense, slanted or incorrect in any way, let me know!
I do not know what to do with the filename. I propose to keep them sp-path and such, to avoid losing SVN history, which is absolutely unacceptable to me. (I don't know how to rename files in SVN, is that possible?) Note that we actually already have a file called svg-path...
If no (negative) comments have reached me, I'd like to start this in a week or two. I really think it clears up things. It is sort of a first step into grouping things.
Thanks, Johan

I do not know what to do with the filename. I propose to keep them sp-path and such, to avoid losing SVN history, which is absolutely unacceptable to me. (I don't know how to rename files in SVN, is that possible?)
svn move|mv|rename|ren renames the file while keeping history. This reason
alone is enough to get rid of cvs ;)

Thanks for the quick reply :-) (and welcome back to Inkscape dev team I guess ! :)
I just noticed the rename command in TortoiseSVN (man do I love the program); sorry I didn't look earlier myself...
-johan
________________________________
From: Aubanel MONNIER [mailto:aubanel@...400...] Sent: donderdag 13 maart 2008 19:34 To: Engelen, J.B.C. (Johan) Cc: inkscape-devel@lists.sourceforge.net Subject: Re: [Inkscape-devel] Renaming SPObjects proposal
I do not know what to do with the filename. I propose to keep them sp-path and such, to avoid losing SVN history, which is absolutely unacceptable to me. (I don't know how to rename files in SVN, is that possible?)
svn move|mv|rename|ren renames the file while keeping history. This reason alone is enough to get rid of cvs ;)

J.B.C.Engelen@...1578... wrote:
SPPath represents svg:path in the SVG. When svg:path is added to SVG, Inkscape immediately generates an SPPath for it. I therefore propose to rename it to something that reflects this aspect of SPPath: that it is directly linked to something in SVG. SPDesktop for example is *not*. SPDesktop => SPDesktop, stays the same SPPath => SVGPath, meaning it represents some element in the SVG. SPShape => SVGShape (since all its derivates are SVG elements) SP_IS_PATH => IS_SVG_PATH (I never understood why it isn't named IS_SP_PATH)
SPNamedview => SVGNamedview ?
I thought there was already a plan for this on the wiki somewhere. IIRC the idea was to remove the SP prefixes from everything and put them into appropriate namespaces.
Mental?
Aaron Spike

Thank you very much Aaron. http://wiki.inkscape.org/wiki/index.php/SubsystemRearchitecture
Which means I'll start with it pretty soon. It's fun/dumb work :) I will not yet move files and such. Just changing names and putting it in right namespace. I don't think macros can be put in a namespace, so SP_IS_PATH => SVG_IS_PATH? Then afterwards we can take care of renaming files and moving them to /src/svg.
Cheers, Johan
-----Original Message----- From: Aaron Spike [mailto:aaron@...749...] Sent: donderdag 13 maart 2008 20:55 To: Engelen, J.B.C. (Johan) Cc: inkscape-devel@lists.sourceforge.net Subject: Re: [Inkscape-devel] Renaming SPObjects proposal
J.B.C.Engelen@...1578... wrote:
added to SVG, Inkscape immediately generates an SPPath for it. I therefore propose to rename it to something that reflects this aspect of SPPath: that it is directly linked to something in SVG. SPDesktop for example is *not*.
SPDesktop => SPDesktop, stays the same SPPath => SVGPath, meaning it represents some element in the SVG. SPShape => SVGShape (since all its derivates are SVG elements) SP_IS_PATH => IS_SVG_PATH (I never understood why it isn't named IS_SP_PATH)
SPNamedview => SVGNamedview ?
I thought there was already a plan for this on the wiki somewhere. IIRC the idea was to remove the SP prefixes from everything and put them into appropriate namespaces.
Mental?
Aaron Spike

On Mar 13, 2008, at 1:22 PM, J.B.C.Engelen@...1578... wrote:
Which means I'll start with it pretty soon. It's fun/dumb work :) I will not yet move files and such. Just changing names and putting it in right namespace. I don't think macros can be put in a namespace, so SP_IS_PATH => SVG_IS_PATH? Then afterwards we can take care of renaming files and moving them to /src/svg.
Macros MUST GO AWAAAAYY!!!!!!
Bad, bad, evil macros.
(seriously, those mainly date from C code usage and can be replaced by C++ things, instance methods or static class methods)

On Thu, 13 Mar 2008 19:21:42 -0700, "Jon A. Cruz" <jon@...18...> wrote:
(seriously, those mainly date from C code usage and can be replaced by C++ things, instance methods or static class methods)
Not entirely; not yet. Those things are still GObject "classes".
But we can replace macros with inline functions.
-mental

Does the wiki page mean that:
SPPath --> Inkscape::SVG::Object::Path (to /src/svg/object/path.cpp or --> Inkscape::SVG::Path (to /src/svg/object/path.cpp ??)
I think the first, right? Johan
-----Original Message----- From: Engelen, J.B.C. (Johan) Sent: donderdag 13 maart 2008 21:23 To: 'Aaron Spike' Cc: inkscape-devel@lists.sourceforge.net Subject: RE: [Inkscape-devel] Renaming SPObjects proposal
Thank you very much Aaron. http://wiki.inkscape.org/wiki/index.php/SubsystemRearchitecture
Which means I'll start with it pretty soon. It's fun/dumb work :) I will not yet move files and such. Just changing names and putting it in right namespace. I don't think macros can be put in a namespace, so SP_IS_PATH => SVG_IS_PATH? Then afterwards we can take care of renaming files and moving them to /src/svg.
Cheers, Johan
-----Original Message----- From: Aaron Spike [mailto:aaron@...749...] Sent: donderdag 13 maart 2008 20:55 To: Engelen, J.B.C. (Johan) Cc: inkscape-devel@lists.sourceforge.net Subject: Re: [Inkscape-devel] Renaming SPObjects proposal
J.B.C.Engelen@...1578... wrote:
added to SVG, Inkscape immediately generates an SPPath for it. I therefore propose to rename it to something that reflects
this aspect
of SPPath: that it is directly linked to something in SVG.
SPDesktop
for example is *not*.
SPDesktop => SPDesktop, stays the same SPPath => SVGPath, meaning it represents some element
in the SVG.
SPShape => SVGShape (since all its derivates are SVG elements) SP_IS_PATH => IS_SVG_PATH (I never understood why it isn't named IS_SP_PATH)
SPNamedview => SVGNamedview ?
I thought there was already a plan for this on the wiki somewhere. IIRC the idea was to remove the SP prefixes from everything and put them into appropriate namespaces.
Mental?
Aaron Spike

On Thu, Mar 13, 2008 at 09:27:25PM +0100, J.B.C.Engelen@...1578... wrote:
Does the wiki page mean that:
SPPath --> Inkscape::SVG::Object::Path (to /src/svg/object/path.cpp
This one is correct
or --> Inkscape::SVG::Path (to /src/svg/object/path.cpp ??)
There are other non-Object code that will be going under svg/, so distinguishing the Objects (both by subdir and namespace) from that is worthwhile. It looks like there is also canvas stuff, color stuff, and some utilities.
Thanks for undertaking this, it's one of the major tasks for the refactoring. Would you mind also updating the SubsystemRearchitecture page as you go, to add clarifications like this?
Bryce
participants (6)
-
unknown@example.com
-
Aaron Spike
-
Aubanel MONNIER
-
Bryce Harrington
-
Jon A. Cruz
-
MenTaLguY