On Thu, Sep 25, 2008 at 11:25 AM, Ted Gould <ted@...11...> wrote:
> So we have full screen (F11), show/hide dialogs (F12), and now
> think it starts getting confused. Can you perhaps merge your
> functionality with shiw/hide dialogs and rename it "hide UI" or
> "slideshow mode"?
How about "Show/Hide toolbars"?
But if it's not only toolbars but also dialogs, don't we need a more
For me at least it makes sense with how I work on a document. I tend
stay at a high level and then go in an tweak something. This is
probably because, for the most part, the things I do are relatively
simple compared to other documents. But, having a whole undo stack is
overly complex and too much to think about.
You absolutely don't need to think about it :) Just press ` and you
go back to old zoom. If it's not "old enough", press it again until
you're where you want to be. What can be simpler?
I guess for me, it's "undo
Well, having two stacks for the same thing seems terribly confusing to
me. Stack is by itself a simple concept already. Are you sure we
really need it?
I also like having it tied to the physical action of
letting go of the key -- as this also reminds me that I can undo :)
But using a whole finger - and partly, a whole hand - just as a
reminder... isn't it wasteful? :)
I'm also not aware of any analogs of this UI ("zoom in while key
pressed") in other software. Are you?
It is tool agnostic, but only grabs the points and does something
special with them in the node tool. Otherwise it works off of the
As pointed out already, you can always press 3 to zoom to selection,
then ` to go back. Using a single letter for something that's not a
tool is inconsistent - we have reserved this for tools only.
I have first to upgrade gtk and gtkmm, before that it fails to compile
for me so I cannot test this new functionality. As soon as I can I
will test it and then get back with a more substantiated opinion :)
Inkscape. Draw Freely.