
I found that to make rendering of feImage filters work correctly I have to call Gtk::Main::init_gtkmm_internals() before trying to use Gdk::Pixbuf. If this is not done it complains about not being able to wrap GdkPixbuf. With this change it suddenly seems to work just fine.
However, I have no idea where it should be put. At the moment I put it in nr-filter-image.cpp (because that was were the problem was occurring), but it would probably be better to do it while starting Inkscape. However, it should also be called for Inkview. And perhaps it should be called after/before some other things?
So, if someone who is a bit more familiar with GtkMM (and Inkscape's initialization) could have a look at this, that would be great. This very simply change will make feImage's with references to files work automagically :) (There are probably still a few caveats, but still.)

On Tue, Jan 6, 2009 at 10:16 AM, Jasper van de Gronde <th.v.d.gronde@...528...> wrote:
So, if someone who is a bit more familiar with GtkMM (and Inkscape's initialization) could have a look at this, that would be great. This very simply change will make feImage's with references to files work automagically :) (There are probably still a few caveats, but still.)
How about putting it into main() ? It's the usual place for such things.

bulia byak wrote:
On Tue, Jan 6, 2009 at 10:16 AM, Jasper van de Gronde <th.v.d.gronde@...528...> wrote:
So, if someone who is a bit more familiar with GtkMM (and Inkscape's initialization) could have a look at this, that would be great. This very simply change will make feImage's with references to files work automagically :) (There are probably still a few caveats, but still.)
How about putting it into main() ? It's the usual place for such things.
That's exactly my problem, what is the right main? For example, when searching for Gtk::Main I find it is used in several different places. Is there one "right" place to put such things? And should init_gtkmm_internals() be called before or after Gtk::Main (or doesn't it matter)?

On Sat, Jan 10, 2009 at 6:54 AM, Jasper van de Gronde
That's exactly my problem, what is the right main? For example, when searching for Gtk::Main I find it is used in several different places. Is there one "right" place to put such things? And should init_gtkmm_internals() be called before or after Gtk::Main (or doesn't it matter)?
The main main is in main.cpp :) it has no prefixes. It calls Application::run which in turn calls either main_gui or main_console.

bulia byak wrote:
The main main is in main.cpp :) it has no prefixes. It calls Application::run which in turn calls either main_gui or main_console.
The whole init sequence is currently a big pile of spaghetti. In particular, the functions sp_main_gui and sp_main_console should be in different files, because they are called in e.g. application/application.cpp. I will fix this once my patch for GOption that fixes the Windows brain damage lands in a stable Glib release. I just don't want to waste time on sanitizing popt code.
If someone could apply my patch to our devlibs, I could do this sooner, because it doesn't affect Linux or Mac OS X. It's the last non-obsoleted patch on this bug: http://bugzilla.gnome.org/show_bug.cgi?id=522131
Regards, Krzysztof Kosiński.

bulia byak wrote:
On Sat, Jan 10, 2009 at 6:54 AM, Jasper van de Gronde
That's exactly my problem, what is the right main? For example, when searching for Gtk::Main I find it is used in several different places. Is there one "right" place to put such things? And should init_gtkmm_internals() be called before or after Gtk::Main (or doesn't it matter)?
The main main is in main.cpp :) it has no prefixes. It calls Application::run which in turn calls either main_gui or main_console.
From what I can tell this is not used by inkview. So I'll just add it to both main.cpp and inkview.cpp and hope that the order is okay (it doesn't give any problems for me).
participants (3)
-
bulia byak
-
Jasper van de Gronde
-
Krzysztof Kosiński