On Wed, Jun 25, 2014 at 08:49:40PM +0200, Johan Engelen wrote:
On 25-6-2014 20:19, Krzysztof Kosiński wrote:
> 2014-06-25 17:41 GMT+02:00 Josh Andler <scislac@...400...>:
>> Hey Krzysztof,
>>
>> Thank you for the update. After playing with that cgal toy here, it is
>> indeed disappointing... definitely a shame their implementation wasn't more
>> robust. Given that the first half of GSoC has had a lot of unexpected time
>> eaten up by University stuff, in addition to API related tasks you've
>> designated, would you be willing to put forth an estimated timeline for what
>> you would expect to accomplish in the second half?
> In the next two days, I want to complete some of the path API rewrite.
> I want to do at least some of the following:
> 1. Rename Path to SubPath,
> 2. Rename PathVector to Path,
I agree that PathVector is a poor name (plus I am not sure if inheriting
from std::vector is allowed..., definitely needs improvement as you've
planned).
Inheriting instead of lifting is definitely an antipattern (it's a
shame it's such a pain to lift in c++). We should definitely fix this.
But I think we should not rename Path. I think it is a better name
than
SubPath, which could be taken to mean a part of a contiguous path,
instead of its intent "contiguous path". It would be strange for a user
that only works with contiguous paths to use SubPath instead of Path, I
think. (let's not make 2Geom too SVG-biased in naming)
So let's come up with a better name for PathVector.
Some names that come to mind:
MultiPath
A little vague.
PathSet
It's an ordered set.
PathVector is my vote :)
njh